한국어
Search
K

升级到ALC V2

由V1升级到 V2

1. 添加ALC Library从属项目

从 ONE store SDK ALC v2 开始,通过 maven 提供分发。 通过 maven 应用 SDK,需要应用以下内容。
删除ALC AAR 文件
删除Project内 libs 文件夹的 alc-android-library_v1.0.0.aar文件
添加Maven 从属性
项目顶端的 build.gradle 文件中,注册ONE store maven 地址。
Android Studio (version: bumblebee),在 settings.gradle添加
...
buildscript {
repositories {
...
    maven { url 'https://repo.onestore.co.kr/repository/onestore-sdk-public' }
}
}
...
下面应用软件的 build.gradle 文件中,添加 ONE store ALC Library从属项目
...
dependencies {
def onestore_sdk_version = "2.0.0"
implementation "com.onestorecorp.sdk:sdk-licensing:$onestore_sdk_version"
}
...
AndroidManifest.xml中添加queries
以下两种情况,请参考ONE store 公告进行设置。
Android 11 (Target SDK 30) 以上,请添加以下内容
Android 11 以上 (Target SDK 30 以上),请添加 queries
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="com.dev.sample">
<queries>
<intent>
<action android:name="com.onestore.extern.licensing.LicensingService.ACTION" />
</intent>
<intent>
<action android:name="android.intent.action.VIEW" />
<data android:scheme="onestore" />
</intent>
</queries>
...

2. 添加SDK Configuration

在ALC v2中,为使用SDK所需的必要param,必须先应用sdk-configuration Library. 为应用此功能,请在 build.gradle文件中添加ONE store sdk-configuration Library从属项目。
...
dependencies {
def onestore_configuration_version = "1.0.0"
implementation "com.onestorecorp.sdk:sdk-configuration-kr:$onestore_configuration_version"
}
...
Last modified 4mo ago